Resolved
Issue has been resolved. The system is now fully operational.
Monitoring
Between 3:14 PM and 3:38 PM UTC, we experienced a period of degraded performance with our API. The root cause has been addressed, and system performance has returned to normal. we are continuing to monitor the situation closely